Connector Troubleshooting: What does "Authentication with marketing provider failed" mean?

If you are using our Marketo Connector, you may receive some variation of the below error message:

 

Authentication with marketing provider failed. Make sure that you have entered the correct credentials.

 

Why am I seeing this?

 

Marketo requires that BrightTALK re-authenticate every time we sync data and if that authentication fails, this error message will be sent back.  

 

How do I fix this?

 

If you are only seeing these errors sporadically (i.e. once every couple of days) then there is no cause for concern- occasionally the re-authentication process takes longer than expected and will "time out" before re-attempting the same sync the following hour (with no loss of data).

 

However, if these errors are happening every hour, then you may need to update your Marketo API Credentials.  This can be done by going to your Connector in BrightTALK and selecting the "Setup" tab:

 

setupbutton.png

 

Once in the setup tab, simply update the Client ID, Client Secret, Identity Service URL, and Rest Service URL fields with your API credentials and click "Authenticate."  This will re-authenticate your Marketo Connector and should resolve these errors moving forward.

 

For information on how to find your API credentials, please see this article:   https://support.brighttalk.com/hc/en-us/articles/115005135953-BrightTALK-Connector-for-Marketo-Authenticate-BrightTALK-with-Your-Marketo-Instance

 

Note: You may also want to run a "Historical Sync" after resolving these errors to ensure that you are not any missing data.  Information on how do this can be found here:  https://support.brighttalk.com/hc/en-us/articles/360006115153-What-is-a-Historical-Sync-

 

 

 

 

 

 

 

 

Comments







Powered by Zendesk