Connector Troubleshooting: Leads are missing in my HubSpot instance

 

If you are using our HubSpot Connector and find that leads from BrightTALK are missing in your HubSpot instance, please follow the below steps to resolve:

 

Step 1: Check your HubSpot Lists

Step 2: Run a Historical Sync

Step 3: Check for Errors

Step 4: Identify Missing Leads

  

 

 

 

Step 1: Are your BrightTALK Webinars Tracked using HubSpot Lists?

 

While there are a number of ways to track BrightTALK leads and webinars in HubSpot, we recommend using either "Active" or "Static" Lists.  Both of these methods will allow you to maintain a history and accurate count of all leads that have registered or attended your events.  For information on how to set up these lists, please see our HubSpot Best Practices

 

 

 

 

 

 

Step 2: Have you tried running a historical sync?

If you’ve already separated your webinars into Lists and you’re still missing leads, it’s possible that you may need to run a historical sync.  For more information on how to do this, please this article: What is a Historical Sync

 

 

 

 

Step 3: Are you seeing any errors in the Job History?

 

If after running a historical sync you are still seeing missing leads, please check whether or not there are errors on your Connector by going to the “Job History” page on your Connector:

 

hubspotjobhistory.png

 

If you see red “Error” messages or you see numbers populated next to "Records Failed" in the Job History, there may be an issue you need to resolve in order to get the Connector working again.  Most HubSpot errors fall into one of two categories:

 

Authentication Errors: These are errors that occur when BrightTALK's connection with HubSpot has failed.  This often happens when the HubSpot admin that originally authorize the connection leaves your company (and has their account deleted) or has their permissions in HubSpot adjusted.

 

To fix these errors, please have your HubSpot admin "Re-Authenticate" your Connector from the "Setup" tab:

hubspotreauth.png

Field Mapping Errors: If you are attempting to map a BrightTALK field to a HubSpot field that uses a menu of drop-down or picklists values, you may need to either adjust your HubSpot list to accommodate the BrightTALK values or work with our support team to align BrightTALK's values with your values. 

 

A common example of this is the Country field- BrightTALK sends Countries through using their full name- i.e. "United Kingdom."  If you are using Country Codes (i.e. "UK"), our country value will be rejected by HubSpot, causing the lead to fail to sync.

 

If you need BrightTALK Support to adjust our values, please make fill in this document by either downloading it or making a copy of it in Google Sheets.  Once completed, email support@brighttalk.com with the completed sheet and your Channel Name and asked them for assistance with transforming these values.

 

 

 

 

Step 4: Can you identify which leads are missing?

 

If you've completed Steps 1-3 and you're still missing leads in HubSpot, we'll need to identify an example of at least one lead that failed to sync.  To do this, we recommend comparing what you see in HubSpot with what you see in either your BrightTALK webinar reports or channel reports

 

Once you've done that, please contact support@brighttalk.com and let them know the email addresses of the leads you're not seeing and that you've already completed steps 1-3 in this guide.

 

 

 

 

 

 

 

Comments







Powered by Zendesk